Firebug for Firefox5/Aurora? Get version 1.8!

Just a quick tip that if you are a developer and you lately upgraded Firefox4 to Firefox5 (or why not give Aurora a try?) it tells you that Firebug is not compatible and can’t find an upgrade.

However, there is a compatible version of Firebug (v1.8) available for you: get it here.

Now you can get the latest Firefox goodness and still debug your code.

About Chris Heilmann

Principal Evangelist at Mozilla for HTML5 and open web. Let's fix this!

More articles by Chris Heilmann…


  1. Kevin Dangoor

    I just heard earlier today that Firebug 1.7.1 (the current release on AMO) is compatible with Firefox 5.

    (Note that Aurora is Firefox 6 now and there is a crashing bug affecting Firebug on the new Aurora. This bug is already fixed but needs to be merged into Aurora builds.)

    May 26th, 2011 at 12:00
  2. Art

    how to do that?..

    Can you explain? thank you so much..

    July 14th, 2011 at 02:17
  3. Cal

    Thanks! Helps a lot.

    August 2nd, 2011 at 18:31
  4. Marvin Froeder

    No joy with aurora, it says it isn’t compatible 7.0a2. Tried 1.8.0 to 1.8.1

    August 12th, 2011 at 10:47
  5. Kevin Dangoor

    I believe Honza told me that Firebug 1.9 is needed for Firefox 7.

    August 12th, 2011 at 20:53
  6. Ref

    yep i just tried and firebug 1.9 from the link Kevin gave is working fine on aurora

    thanks for sharing mate!

    August 16th, 2011 at 02:37
  7. Diptiranjan

    Hi ,

    Can anyone tell me is mozilla firefox 6 supports firebug and YSlow Add-On .

    September 9th, 2011 at 07:55

Comments are closed for this article.